macOS Mojave 10.14系统Safari 12.0扩展插件无法安装不兼容的解决办法-免费薅羊毛、技术分享、活动收集、VPS测评、电影影视、项目方案、学习教程、吹一天牛逼、乐一切逗事!

当前位置:首页 - Apple苹果控 - 正文

君子好学,自强不息!

       MacOS Mojave 10.14系统升级以来着实稳定迅速了很多,个人体验也觉得非常不错。但是每次升级系统带来的烦恼就却是各种软件和拓展插件的不兼容和闪退,导致很多神器或使用习惯的软件插件不能再使用了。


      这次MacOS Mojave 10.14系统的升级,Web浏览器Safari 12.0 版本同样也升级了其Safari拓展插件的隐私和安全性的检测和拦截。未经过苹果Apple官方认证审核通过的或者说是不经过审核的安全Safari拓展插件将不给予安装或拦截。而且对于一些像uBlock Origin等广告隐私拦截的插件都会给予拖慢浏览速度及性能的安全性标注提醒。


     当我们从低于macOS Mojave 10.14系统的版本升级到 macOS Mojave 10.14系统的时候,Web浏览器Safari同样也升级到了Web浏览器Safari 12.0版本。我们打开浏览器会发现我们之前安装的很多Web浏览器Safari拓展插件不见了或者少了几个。更郁闷的是像clean my mac等第三方系统维护性软件也不再支持对新Safari12.0版本的拓展插件维护。


      通过这几天的四处请教搜寻,偶然发现LanceLee大神已经找到了暂时的macOS Mojave 10.14系统Safari 12.0扩展插件无法安装不兼容问题的解决办法。我们便能将老旧版本的Safari拓展插件安装到新系统的Safari暂时使用。


      下面来详细说一下步骤:


      我们首先打开finder“访达”利用显示隐藏文件快捷键“ Command+Shift+. ”显示系统隐藏目录。或者直接在finder“访达”下利用快捷键“ Command+Shift+G ”前往文件夹:“ ~/Library/Safari/Extensions ”,这就是Safari拓展插件目录的路径。安装新系统版本后,之前我们老系统版本安装的所有插件拓展也都再里面。

 

      找一个新版本Safari 21.0不支持,我们想要恢复的Safari拓展插件,以“ .safariextz ”结尾的后缀,拖到桌面,用解压软件如BetterZip,点文件右键解压成文件夹。


      进入Safari浏览器的偏好设置,高级选项卡下面,勾选“ 在菜单栏中显示“开发”菜单 ”。回到Safari浏览器菜单栏,点击开发菜单,点选“ 显示扩展构建器 ”选项,确认打开扩展构建器。


      在“扩展构建器”页面左下角点击“ + ”号添加扩展,找到并选择我们刚刚解压的“safariextension”拓展文件夹。


      点击右上角“运行”,弹出提示点击确认,会要求系统权限,我们输入本机的管理员用户密码,便完成了插件安装。


      这样我们便能暂时使用运行未经过苹果Apple审核通过的Safari拓展插件了。但是重启Safari一次,我们就要按上述方法重新启动一次插件。

     而且使用过多的拓展插件的确会慢浏览速度,如果遇上像一些油猴脚本对网页支持不好的也会影响网页的打开速度和功能。因此大家自己还是权衡利弊尽量安装一些特别需要且对浏览器支持较好的Safari拓展插件。

吹乐了
第一时间收集更多薅羊毛免费活动,定时分享网络应用教程、公益账号,请关注我们的公众号。文章如果对您有所帮助,您也可以进行打赏,请吹乐了喝杯咖啡哦~
微信公众号:吹乐了
微信号:chuill_com
博客网址:chuill.com
未注明出处均为原创、转载需注明转自:吹乐了https://chuill.com/
联系方式:dlqdlq#gmail.com

打开支付宝首页顶部搜索下面数字:

532530847

本文来源:吹乐了

本文地址:https://chuill.com/post/24.html

关注吹乐了公众号:微信公众号搜索“吹乐了”

版权声明:如无特别注明,转载请注明本文地址!

发表评论

必填

选填

选填

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。


请先登陆再评论,若不是会员请先注册